Internet at the beach

Submitted by tarvid on Sun, 08/24/2014 - 09:34

I don't get to the beach often but I often suffer from Internet withdrawal. Not my only addiction. My crappy LG 39C tracfone is adequate for reading email but impossible for me to type on. A Bluetooth keyboard would help that. The keyboard on my aging Acer laptop is barely adequate for the current task. To make it play, I need connectivity.

There are three rational options in Ocean City - xfinitywifi, cablewifi and HighPoint (a branch of CityWide).  The first two are already paid for in connection with Comcast in Galax and Cox in Fairfax. I am going to have to cough up $23.99 to use HighPoint. I can get a connection to xfinitywifi on the third floor street side balcony which also works on my phone in the parking lot. The much preferred work location is the ocean side balcony. From there I can get a weak but workable connection to SeaWatch next  door. I can even get into the Verizon router. CityWide has two access points  pointed at my ocean side balcony with more than enough signal strength to blow the others away. I cough up the $23.99.

I bought a device from Microcenter to relay traffic from an inbound wireless connection and several  wifi devices. I have three, the LG39C, a Nook HD+ and the Acer laptop. My wife has an iPhone, grandson has a Samsung, son-in-law an iPhone and daughter has an iPhone and an iPad. With the CityWide connection we would wind up taking turns.  The device is a TP-Link TL-MR3040. It has three modes - 3/4g, wisp client and AP. 3/4g has charm if I ever get my FreedomPop Bolt to work but wisp client is what I am after. After a short dialog with the setup wizard I am told I must reboot. After reboot, the device is dead. After much gnashing, I paid CityWide, downloaded new firmware, reflashed the router and everything works. Sort of.

All three of my potential sources initially dump you in a "walled garden". Say the magic words (user name and password) and can get out to the rest of the 'net. The TP-Link router doesn't know how to do that.But I have an Internet connection and a spare Ethernet connection. Switch the TP-lINK to AP mode and potentially I can create my won wireless network.

To get the Acer to talk to the TP-Link, I tell Ubuntu not to use the wired connection for Internet and give the Ethernet port an IP address - ifconfig eth5 192.168.0.2

I tell Linux to route with  - iptables -t nat -A POSTROUTING -o eth5 -j MASQUERADE - and - iptables -A FORWARD -i wlan3 -o eth5 -j ACCEPT

I enable the ACER to serve DNS with apt-get install dnsmasq.

Finally I tell the kernel to forward - echo 1 > /proc/sys/net/ipv4/ip_forward

It doesn't sound all that bad but I can assure you it took more than 5 minutes the first time.

Surf is up today!